• 👏 Bienvenido a nuestra comunidad Excel

    ¿Todavía no estás registrado? 😲

    Registrate gratis aquí y podrás:

    💪 Hacer preguntas a los expertos
    ⬇️ Descargar ejemplos y plantillas
    🏅 
    Acceder a contenidos premium

SUMAR MES Y AÑO

Una pregunta me podrias explicar esta formula lo que esta en negrita.

=SUMAR.SI.CONJUNTO($D$4:$D$23;$C$4:$C$23;">="&FECHA(J$3;MES($I4&1);1);$C$4:$C$23;"<="& FIN.MES(FECHA(J$3;MES($I4&1);1);0))
 

silvia quispe

Well-known member
Código:
=SUMAR.SI.CONJUNTO(D4:D23,C4:C23,">="&H4,C4:C23,"<="&FIN.MES(H4,0))
En tu formula señalas que C4:C23 debe ser >= H4
H4 es un texto que dice ENERO
y lo que tu tienes en C4:C23, son números que representan fechas.
Por ese motivo construí una fecha
FECHA(J$3;MES($I4&1);1)
J3 es el año, el mes Texto lo convertí en mes número, y 1 para arrancar del primer día del mes.

En la siguiente parte, como ya tenemos la fecha inicial, solo convertimos con FIN.MES, la fecha inicial, en el último día del mes.

Sin embargo, yo me quedaría con la tabla dinámica, ya que no tienes que utilizar fórmulas, si la tabla de datos sufre alguna modificación, tan solo actualizar la Tabla D. los valores se actualizan.

saludos,
 
Arriba