Bienvenido a la mayor comunidad de usuarios EXCEL

Regístrate gratis ahora para ver contenidos y descargas sin restricciones!

Regístrate gratis

Separación de fórmulas complejas en múltiples líneas

Oscar_Mendez_Roca

Moderator
Registrado
30 Dic 2020
Mensajes
267
Que tal, en gratitud a lo que he aprendido hasta ahora en el Foro, me permito realizar un interesante aporte que vi en internet.

En el reporte adjunto, y por medio de una compleja fórmula de multiples condiciones, se determina la atención o no (ABIERTO / CERRADO) según varios criterios (día de la semana y horarios diferenciados segun el día).

El truco consiste en utilizar la combinación de techas ALT+ENTER cuando se redacta la fórmula, de manera que la misma se pueda visualizar en múltiples líneas y sea más "fácil" su correción y/o interpretación, como se muestra a continuación:

Código:
=SI(DIASEM(B8;1)<>1;
SI(DIASEM(B8;1)<7;
SI(O(
Y(C8>=$C$4;C8<$D$4);Y(C8>=$C$5;C8<$D$5));
"ABIERTO";"CERRADO");
SI(Y(C8>=$E$4;C8<$E$5);
"ABIERTO";"CERRADO"));
"CERRADO")


Espero les sea útil.
 

Adjuntos

    Sin permisos de acceso

Héctor Miguel

Moderator
Registrado
26 Mar 2005
Mensajes
10.554
medio de una compleja fórmula de multiples condiciones, se determina la atención o no (ABIERTO / CERRADO) según varios criterios (día de la semana y horarios diferenciados segun el día)
si los horarios "de atencion" son:

abierto:
lunes de 8:00 a 14:00
viernes de 12:00 a 18:00
sabado de 9:00 a 15:00

cerrado:
todo fuera de lo anterior (?)

o no entiendo la logica aplicada para determinar el estado de atencion ?
o caiste en la trampa de un exceso de funciones si(... y(... o(... anidadas o en secuencia (?)
 

Adjuntos

    Sin permisos de acceso

Oscar_Mendez_Roca

Moderator
Registrado
30 Dic 2020
Mensajes
267
Estimado Hector,

Evidentemente el ejemplo no explica en detalle la lógica planteada (atención lunes a viernes de 8 horas , sábado solo 6 horas y domingo cerrado).

Asimismo la fórmula de varios SI anidados puede reemplazarse por otra combinación de fórmulas como MEDIANA o similares y reducir la longitud del enunciado considerablemente.

Mi objetivo, sin embargo, era mostrar una alternativa práctica de escribir fórmulas complejas en varias líneas, que faciliten tanto la redacción como interpretación del enunciado final.

Agradezco tu análisis en cuanto al desempeño de otras alternativas, y espero seguir aprendiendo y aportando en el Foro.
 

Héctor Miguel

Moderator
Registrado
26 Mar 2005
Mensajes
10.554
Mi objetivo... era mostrar una alternativa práctica de escribir fórmulas complejas en varias líneas, que faciliten tanto la redacción como interpretación del enunciado final
(y)
lo que pasa es que las formulas "complicadas" no tienen por que serlo (siempre)

en el adjunto va una hoja oculta (veryhidden), muestrala y analiza cambios sustituyendo excesos de si(...
(es un caso real que -en su momento- fue util para quien la desarrollo)
y combinando esa tecnica con "un ojo entrenado" (y algunas herramientas disponibles) se puede prescindir de la tecnica (?)
 

Temas similares

Arriba