• 👏 Bienvenido a nuestra comunidad Excel

    ¿Todavía no estás registrado? 😲

    Registrate gratis aquí y podrás:

    💪 Hacer preguntas a los expertos
    ⬇️ Descargar ejemplos y plantillas
    🏅 
    Acceder a contenidos premium

Ordenar una tabla según unas condiciones

jmsuarg

New member
Hola, buenas noches.
Necesito ordenar una tabla, rango D19:F25, en función del número de facturas en orden ascendente y luego por importe total también ascendente. He realizado la tabla pero al aplicar el filtrado no realiza la acción.
En otro momento me indicaron estar fórmulas, pero no las entiendo.
=INDICE(C$21:C$26;COINCIDIR(10^6*F21+G21;INDICE(10^6*CONTAR.SI(D$3:D$14;B$21:B$26)+SUMAR.SI(D$3:D$14;B$21:B$26;H$3:H$14););))
=AGREGAR(15;;CONTAR.SI(D$3:D$14;B$21:B$26);FILAS(F$21:F21))
=RESIDUO(AGREGAR(15;;10^6*CONTAR.SI(D$3:D$14;B$21:B$26)+SUMAR.SI(D$3:D$14;B$21:B$26;H$3:H$14);FILAS(G$21:G21));10^6)
¿Alguien puede ayudarme con una forma más sencilla?
Adjunto el documento.
Muchas gracias.
 

Adjuntos

Buenos días ajmsuarg.

No se el porque no se ordenan los datos correctamente con el rango D19:F25 convertido en tabla.
Una solución, poco elegante, es copiar este rango a otro lugar pegando todos los datos como valores, entonces el rango lo convertimos en una tabla, le ponemos los criterios de ordenación y ahora si que los ordena correctamente.

Adjunto fichero con mi poco elegante propuesta.

Cuidaros y cuidarnos mucho.

Saludos, Servando.
 

Adjuntos

Héctor Miguel

Well-known member
Necesito ordenar una tabla, rango D19:F25, en función del número de facturas en orden ascendente y luego por importe total también ascendente
tu rango [D20:F25] no se ordena debido a que toda la tabla son solo fórmulas
- las fórmulas y las (re)ordenaciones no son compatibles

si conviertes la primera columna a valores, ese "problema" desaparece
 

jmsuarg

New member
Buenos días ajmsuarg.

No se el porque no se ordenan los datos correctamente con el rango D19:F25 convertido en tabla.
Una solución, poco elegante, es copiar este rango a otro lugar pegando todos los datos como valores, entonces el rango lo convertimos en una tabla, le ponemos los criterios de ordenación y ahora si que los ordena correctamente.

Adjunto fichero con mi poco elegante propuesta.

Cuidaros y cuidarnos mucho.

Saludos, Servando.
Gracias por tu propuesta.
Un abrazo
 

jmsuarg

New member
tu rango [D20:F25] no se ordena debido a que toda la tabla son solo fórmulas
- las fórmulas y las (re)ordenaciones no son compatibles

si conviertes la primera columna a valores, ese "problema" desaparece
Muchas gracias, me ha sido muy útil tu solución.
Mil agradecimientos
Un abrazo
 
Arriba