Espacios en blanco funcion buscar v

Angel Torres

New member
Buen día
Quiero remplazar los valores $- por N/A de la ultima columna

SAI SKU DESCRIPCIÓN PMP
2047 7613326005012 BACTRIM 400/80 MG CON 30 TAB $285.00
18848 7640133685557  IMNOVID 4 MG CAPS C21 $-
18609 A18609 14905 BARRERA CONV PRECOR C/MIC 29MM C5 $-
19163 18133 NEW IMAGEN BOLSA COLOSTO ARO N/A
17608 (01)153901 BOLSA NEW IMAGE BEIGE C/F 44MM $-
18537 18537 BARRERA CONVEXA PRECORT 32MM C5 N/A
1533 7360854 OFT GTS 5ML $598.31
3849 7501043161602 3TC 150MG TAB CAJ C/60 $4,348.62

Estoy utolizando la funcion: =SI.ERROR(BUSCARV(B2,'[6 (version 1).xlsb]SAI Hoja1'!$A$2:$AB$19973,23,FALSO),"N/A")

Pero el si. error no me remplaza los valores $- ya que si existen pero por presentacion tengo que sustituirlos por N/A. ¿ Como puedo sustituir esos valores que no quiero?
 

ServandoV

Active member
Hola Angel (y Torquemada)

Si quieres que al realizar una búsqueda con BUSCARV y que cuando esta no se encuentre te marque N/A, lo que tienes que hacer es quitar el SI.ERROR y dejar la función BUSCARV sola:

=BUSCARV(B2,'[6 (version 1).xlsb]SAI Hoja1'!$A$2:$AB$19973,23,FALSO)

Saludos
Servando Villalón
 

Héctor Miguel

Well-known member
Angel Torres dijo:
Quiero remplazar los valores $- por N/A de la ultima columna ...

... la funcion: =SI.ERROR(BUSCARV(B2,'[6 (version 1).xlsb]SAI Hoja1'!$A$2:$AB$19973,23,FALSO),"N/A")

Pero el si. error no me remplaza los valores $- ...
prueba con:
Código:
=SI.ERROR(SUSTITUIR(BUSCARV(B2,'[6 (version 1).xlsb]SAI Hoja1'!$A$2:$AB$19973,23,FALSO),"$-","N/A"),"N/A")
es posible que no sea requerida la funcion SI.ERROR(... -?-
 
Arriba