• 💪 Demuestra tus super conocimientos de Excel 
    Ayúdanos a contestar estos temas sin respuesta

Registro

¿Todavía no tienes cuenta? Regístrate gratis ahora

Ingresar

¿Ya estás registrado? Ingresa desde aquí

Ayuda formulas busqueda

jesusitocd

New member
Hola a todos y gracias por este foro.
Necesito una ayudida con unas formulas.
Adjunto archivo.
La primera es la J6 es la suma total del motoclub mas inscrito, y la J7 el segundo mas inscrito, pero si hay dos motoclub con los mismos inscritos, siempre me pone el mismo Motoclub y me deberia de poner el siguiente con el mismo numero de inscrito.
La segunda es que me gustaria que en la A5 empezace por el numero 300 y si pongo del 300 en adelante no me da los resultados en la columna J.
Y la tercera es que en la J16 me tien que buscar el el Inscrito con mas Kms columna F que no sea de ningun Motoclub.
Espero me puedan ayudar.
Gracias y unsaludo,
 

Adjuntos

silvia quispe

Well-known member
hola jesusitocd

Primero:
1- no coloques en tus fórmulas condicionales >> "", en tu caso es mejor colocar 0
2- No he revisado tu información a fondo, pero me parece que traes de aquí para allá y de allá para acá, como haciendo referencias circulares :?: :roll: ... la verdad vi un poco y me quedé mareada... , si fuera el caso revisa a fondo todas tus fórmulas, si solo me pareció, haz caso omiso.

Te hice la primera parte de lo que pides, la segunda, creo que lo puedes resolver con el ejemplo.
Hice dos formulas, una con un control en columna auxiliar, y otra sin auxiliar pero Matricial. Escoge la que mas te convenga.

También te hice un ejemplo de la tercera pregunta, aunque no sé si entendí bien. revisa la lógica de las formulas, a ver si es lo que necesitas..

Saludos :wink:
Silvia
 

Adjuntos

jesusitocd

New member
Hola de nuevo y gracias por todo, pero hay un problema en la formula de la columna M, los datos que da no son correctos, y otra cosita es que me gustaria que en vez de empezar en el numero 1 la columna A, empezace en el 300, pero si empiezo en el 300 no me da los datos en el J11 y J12.
Gracias de nuevo y espero me puedan ayudar.
 

silvia quispe

Well-known member
jesusitocd dijo:
pero hay un problema en la formula de la columna M, los datos que da no son correctos,
como así?
si no explicas el problema, como te puedo ayudar?
jesusitocd dijo:
empezace en el 300, pero si empiezo en el 300 no me da los datos en el J11 y J12.
no te da porque utilizas esa numeración para k.esimo..
o bien utiliza la función fila, o bien coloca ese listado de numeros en una columna auxiliar, sin embargo, ademas mientras no expliques lo primero, tampoco podrás adecuar esta...
 

jesusitocd

New member
Hola de nuevo y gracias.
Asi me vale, pero en la celda K16 me tiene que dar el numero del inscrito con mas kms que no sean de un Motoclub, no la suma de los incritos, que en este caso el correcto seria el inscrito 303 celda A8.
Gracias de nuevo.
 

jesusitocd

New member
Hola de nuevo y gracias.
Asi si que me vale, pero cuando esta todo sin datos en la celda L16 me aparece 300 y deberia estar en blanco. Y las Filas M11 y M12 al estar sin datos me aparece #¡NUM! y tambien deberia estar en blanco.
Espero me puedas resolver esto ultimo.
Gracias de nuevo por todo.
 

silvia quispe

Well-known member
hola
jesusitocd dijo:
en la celda L16 me aparece 300
envuelve la formula, con la función SI
Código:
=SI(K16=0,0,INDICE(A5:A1004,COINCIDIR(1,INDICE((D5:D1004="")*(F5:F1004=K16),0),0)))
mi separador de argumentos es la coma, si el tuyo es otro, corriges.
jesusitocd dijo:
Y las Filas M11 y M12 al estar sin datos me aparece #¡NUM!
envuélvelas con SI.ERROR
Código:
=SI.ERROR(INDICE(I$20:I$112,COINCIDIR(K.ESIMO.MAYOR(SI((K$20:K$112)>0,(K$20:K$112)+(FILA(K$20:K$112)/10^10)),FILA(A1)),SI((K$20:K$112)>0,(K$20:K$112)+(FILA(K$20:K$112)/10^10),0),)),"")
-Ojo con el separador de argumentos
-Además es una fórmula matricial, en lugar de Enter ejecuta Control+Shift+Enter, te das cuenta que está correcto, cuando aparecen los { }
-Arrastras la formula hacia la siguiente celda

saludos,
Silvia
 

jesusitocd

New member
Perdona pero me he perdido, entoendo un poco pero no tanto.
Me lo puedes poner tu dentro de la hoja, que no lo entiendo.
 
Arriba