Restar condicionando o excluyendo un Texto

Cualquier otro tipo de consultas sobre la Hoja de Cálculos Excel.
Reglas del Foro
1. Antes de hacer tu pregunta intenta con el buscador de este foro (muchas preguntas ya fueron respondidas antes!)
2. Si haces una nueva pregunta, es muy recomendable que adjuntes el ejemplo Excel para poder comprenderla mejor!
3. Realiza tu pregunta de forma clara, explicando bien cada paso de lo que haces y tendrás más probabilidad de respuesta!
Responder
roalcaino
Miembro Frecuente
Miembro Frecuente
Mensajes: 5
Registrado: 25 Sep 2019 18:47

Restar condicionando o excluyendo un Texto

Mensaje por roalcaino » 11 Oct 2019 14:07

Estimados, estoy generando una planilla de horarios y necesito lo siguiente:

A1 - 09:00
B1 - 19:00
C1 - B1-C1

El problema radica si al cambiar por hora coloco un texto:

A1 - 09:00
B1 - LIBRE
C1 - B1-A1 = #¡VALOR!

En la Planilla tengo además de todas las opciones de horas, la opción LIBRE y DEVOLUCIÓN.

¿Como lo puedo restar y que me entregue valor 0?

Saludos



Avatar de Usuario
Snakejic
Miembro Frecuente
Miembro Frecuente
Mensajes: 852
Registrado: 17 Ago 2017 16:35
Ubicación: Ciudad de México

Re: Restar condicionando o excluyendo un Texto

Mensaje por Snakejic » 11 Oct 2019 14:21

Hola:

Puedes usar SI.ERROR.

Código: Seleccionar todo

=SI.ERROR(B1-A1,0)
Saludos.



roalcaino
Miembro Frecuente
Miembro Frecuente
Mensajes: 5
Registrado: 25 Sep 2019 18:47

Re: Restar condicionando o excluyendo un Texto

Mensaje por roalcaino » 11 Oct 2019 14:27

El problema es que cuando realizo la resta de dos horas, me devuelve 0.

A1 - 09:00
B1 - 19:00
C1 - =SI.ERROR(B1-A1;0) = 00:00

Necesito condicionarla para que cuando se desplieguen las opciones de horas, solo arroje 0 cuando sea un texto.

A1 - 09:00
B1 - LIBRE
C1 - =SI.ERROR(B1-A1;0) = 00:00



Avatar de Usuario
Snakejic
Miembro Frecuente
Miembro Frecuente
Mensajes: 852
Registrado: 17 Ago 2017 16:35
Ubicación: Ciudad de México

Re: Restar condicionando o excluyendo un Texto

Mensaje por Snakejic » 11 Oct 2019 14:42

Sube el archivo



roalcaino
Miembro Frecuente
Miembro Frecuente
Mensajes: 5
Registrado: 25 Sep 2019 18:47

Re: Restar condicionando o excluyendo un Texto

Mensaje por roalcaino » 11 Oct 2019 15:22

Ahí esta, gracias por la ayuda.
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.



Avatar de Usuario
Snakejic
Miembro Frecuente
Miembro Frecuente
Mensajes: 852
Registrado: 17 Ago 2017 16:35
Ubicación: Ciudad de México

Re: Restar condicionando o excluyendo un Texto

Mensaje por Snakejic » 11 Oct 2019 15:45

Te lo devuelvo, chécalo y comenta si así esta bien..

Saludos.
Horario.xlsx
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.



roalcaino
Miembro Frecuente
Miembro Frecuente
Mensajes: 5
Registrado: 25 Sep 2019 18:47

Re: Restar condicionando o excluyendo un Texto

Mensaje por roalcaino » 11 Oct 2019 15:48

Excelente,era precisamente lo que necesitaba, gracias.

Saludos



Responder