Cruzar datos usando tres criterios

Solo consultas sobre Funciones y Fórmulas Excel.
Reglas del Foro
1. Antes de hacer tu pregunta intenta con el buscador de este foro (muchas preguntas ya fueron respondidas antes!)
2. Si haces una nueva pregunta, es muy recomendable que adjuntes el ejemplo Excel para poder comprenderla mejor!
3. Realiza tu pregunta de forma clara, explicando bien cada paso de lo que haces y tendrás más probabilidad de respuesta!
Responder
Santiago82
Miembro Nuevo
Miembro Nuevo
Mensajes: 4
Registrado: 17 Mar 2019 18:50

Cruzar datos usando tres criterios

Mensaje por Santiago82 » 12 Jul 2019 14:18

POR FAVOR QUIERO UNA FORMULA QUE ME DE EL DATO
DEL NUMERO TOMADO DE LA HOJA "A",
EN ESTE CASO EN LA COLUMNA D2 DE LA HOJA B ME DEVUELVA EL NUMERO QUE
CUMPLA LOS CRITERIOS DE CLINICA: PROGRESO, MES: FEBRERO Y VACUNA: BCG
PARA ESTE EJEMPLO EL NUMERO QUE ME TENDRIA QUE DEVOLVER SERIA 0

EN LA HOJA "A" CONTIENE LA CANTIDAD A BUSCAR EN EL RANGO B5:R63
LAS CLINICAS A5:A53
EL MES EN LA CELDA B2
Y LA VACUNA EN EL RANGO B4:R4

LES DEJO EL ARCHIVO PARA QUE SEA MAS FACIL ENTENDERME, MIL GRACIAS

HE INTENTADO HACER USO DE LA FORMULA SUMAPRODUCTO PERO NO TENGO ÉXITO
MUCHAS GRACIAS
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.



Avatar de Usuario
silvia quispe
Miembro Frecuente
Miembro Frecuente
Mensajes: 6633
Registrado: 13 Jul 2010 16:35
Ubicación: Lima-Perú

Re: Cruzar datos usando tres criterios

Mensaje por silvia quispe » 12 Jul 2019 15:02

Hola Santiago..

Me parece que lo del mes, lo tienes mal... :roll: :roll: .. ,parece que los datos están filtrados.. y que antes ha sido una tabla dinámica :?: .. para que puedas trabajar todos los meses, deben estar en la columna.. en fin no estoy segura.. y en todo caso sería así

Código: Seleccionar todo

  =SI(A!$B$2=B!B2,SUMAPRODUCTO((A!$A$5:$A$53=A2)*(A!$B$4:$R$4=C2),A!$B$5:$R$53),0) 
Cuando sea febrero, se llenará febrero, cuando sea marzo, febrero quedará con ceros y solo llenará marzo... :roll:

Mi separador de argumentos es la coma, si el tuyo es otro.. corriges

saludos,
Silvia



Santiago82
Miembro Nuevo
Miembro Nuevo
Mensajes: 4
Registrado: 17 Mar 2019 18:50

Re: Cruzar datos usando tres criterios

Mensaje por Santiago82 » 13 Jul 2019 21:16

Muchas gracias por la fórmula, sí me funciono, te agradezco muchísimo, me has ahorrado mucho tiempo de trabajo y he aprendido algo nuevo, gracias por compartir tus conocimientos



Responder