Intercambiar datos entre hojas de Excel

Solo consultas sobre Funciones y Fórmulas Excel.
Reglas del Foro 1. Antes de hacer tu pregunta intenta con el buscador de este foro (muchas preguntas ya fueron respondidas antes!)
2. Si haces una nueva pregunta, es muy recomendable que adjuntes el ejemplo Excel para poder comprenderla mejor!
3. Realiza tu pregunta de forma clara, explicando bien cada paso de lo que haces y tendrás más probabilidad de respuesta!

Intercambiar datos entre hojas de Excel

Notapor davidestyle » 02 Oct 2018 13:56

Espero que me podais ayudar ya que no tengo manera de hacerlo...

Quiero intercambiar datos entre hojas de cálculo Calc o Excel usando una columna de referencia.
Que me busque en la columna ID de la HOJA2y la contraste con la de la hoja NOMBRES y que ponga el dato de la columna AÑOS que hay en la HOJA2

Os adjunto excell
No tiene los permisos requeridos para ver los archivos adjuntos a este mensaje.
davidestyle
Miembro Frecuente
Miembro Frecuente
 
Mensajes: 22
Registrado: 31 Dic 2014 16:06

Re: Intercambiar datos entre hojas de Excel

Notapor johnmpl » 02 Oct 2018 14:26

Hola, davidestyle!

¿Es esto lo que buscas?
Intercalar_datos_entre_hojas_de_calculo.xlsx

¡Comentas! ¡Bendiciones!
No tiene los permisos requeridos para ver los archivos adjuntos a este mensaje.
Avatar de Usuario
johnmpl
Miembro Frecuente
Miembro Frecuente
 
Mensajes: 1366
Registrado: 26 Oct 2012 14:22

Re: Intercambiar datos entre hojas de Excel

Notapor davidestyle » 03 Oct 2018 03:58

johnmpl escribió:Hola, davidestyle!

¿Es esto lo que buscas?
Intercalar_datos_entre_hojas_de_calculo.xlsx

¡Comentas! ¡Bendiciones!



Esta perfecto!!! muchas gracias!
davidestyle
Miembro Frecuente
Miembro Frecuente
 
Mensajes: 22
Registrado: 31 Dic 2014 16:06

Re: Intercambiar datos entre hojas de Excel

Notapor davidestyle » 26 Nov 2018 13:34

johnmpl escribió:Hola, davidestyle!

¿Es esto lo que buscas?
Intercalar_datos_entre_hojas_de_calculo.xlsx

¡Comentas! ¡Bendiciones!


Hola johnmpl

Como me ayudaste tu la última vez, de cito a ti...
En el archivo que he subido y con la formula que me diste no se porque no funciona ahora...
Le puedes echar un ojo?

Mil gracias!
No tiene los permisos requeridos para ver los archivos adjuntos a este mensaje.
davidestyle
Miembro Frecuente
Miembro Frecuente
 
Mensajes: 22
Registrado: 31 Dic 2014 16:06

Re: Intercambiar datos entre hojas de Excel

Notapor johnmpl » 26 Nov 2018 22:48

Hola de nuevo, davidstyle!

Tienes en los códigos de la columna B varios espacios al final del código, por eso no los encuentra. Como veo que siempre tu código tiene 6 caracteres, puedes probar con la siguiente variante (en B2):

=SI.ERROR(BUSCARV(IZQUIERDA(B2;6);Hoja2!A$2:B$362;2;)&"";"")

y copias hacia abajo. ¡Bendiciones!
Avatar de Usuario
johnmpl
Miembro Frecuente
Miembro Frecuente
 
Mensajes: 1366
Registrado: 26 Oct 2012 14:22


Volver a Funciones y Fórmulas

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados