Problemas con Vlookup (buscarv)

Solo consultas sobre Funciones y Fórmulas Excel.
Reglas del Foro
1. Antes de hacer tu pregunta intenta con el buscador de este foro (muchas preguntas ya fueron respondidas antes!)
2. Si haces una nueva pregunta, es muy recomendable que adjuntes el ejemplo Excel para poder comprenderla mejor!
3. Realiza tu pregunta de forma clara, explicando bien cada paso de lo que haces y tendrás más probabilidad de respuesta!
Responder
Javixu
Miembro Frecuente
Miembro Frecuente
Mensajes: 73
Registrado: 19 Jun 2012 13:39

Problemas con Vlookup (buscarv)

Mensaje por Javixu » 15 Abr 2019 12:48

Hola a todos,

Estoy teniendo muchos problemas con esta función.

Tengo una lista de dos columnas (Col 1:valor a Buscar, Col 2: resultado)

Estoy usando la función buscarv para que al encontrar un valor (o un valor aproximado), me devuelva la celda de al lado, pero siempre me da como resultado el valor de la última celda de la columna 2...

En el ejemplo que adjunto, se ve cómo intento que me busque el valor 90.00 (valor exacto, la mayoría contienen decimales) y me devuelva 1.11, pero me da 1001.

He probado poniendo al final:

=BUSCARV(E1,A1:B117,2,VERDADERO)
=BUSCARV(E1,A1:B117,2, FALSO)
=BUSCARV(E1,A1:B117,2)

y siempre me da 1001 (el último número de la columa 2).
¿Sabéis por qué me ocurre esto? ¿cómo puedo solucionarlo?

Muchas gracias!
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.



Avatar de Usuario
Snakejic
Miembro Frecuente
Miembro Frecuente
Mensajes: 833
Registrado: 17 Ago 2017 16:35
Ubicación: Ciudad de México

Re: Problemas con Vlookup (buscarv)

Mensaje por Snakejic » 15 Abr 2019 12:59

Hola..

Para la búsqueda exacta, solamente te falta aumentar en tu fórmula un ,0 después del 2.

Para búsqueda aproximada tienes que ordenar tus datos por la columna A de menor a mayor.



Avatar de Usuario
silvia quispe
Miembro Frecuente
Miembro Frecuente
Mensajes: 6753
Registrado: 13 Jul 2010 16:35
Ubicación: Lima-Perú

Re: Problemas con Vlookup (buscarv)

Mensaje por silvia quispe » 15 Abr 2019 13:08

hola Javixu (y Snakejic )

A parte de lo que ya te mencionó Snake,
Javixu escribió:
15 Abr 2019 12:48
en el ejemplo que adjunto, se ve cómo intento que me busque el valor 90.00 (valor exacto, la mayoría contienen decimales) y me devuelva 1.11, pero me da 1001.

He probado poniendo al final:

=BUSCARV(E1,A1:B117,2,VERDADERO)
=BUSCARV(E1,A1:B117,2, FALSO)
=BUSCARV(E1,A1:B117,2)

y siempre me da 1001 (el último número de la columa 2).
No te creo :shock: que en la segunda opción, en la que colocaste; Falso, te de 1001. :mrgreen:
a ver, vuelve a intentar :shock:

Otra cosa, 1 equivale a Verdadero, 0 Equivale a Falso, en la ayuda de Excel además te indica que Verdadero ú Omitido es lo mismo..



Javixu
Miembro Frecuente
Miembro Frecuente
Mensajes: 73
Registrado: 19 Jun 2012 13:39

Re: Problemas con Vlookup (buscarv)

Mensaje por Javixu » 15 Abr 2019 13:49

Snakejic escribió:
15 Abr 2019 12:59
Hola..

Para la búsqueda exacta, solamente te falta aumentar en tu fórmula un ,0 después del 2.

Para búsqueda aproximada tienes que ordenar tus datos por la columna A de menor a mayor.
silvia quispe escribió:
15 Abr 2019 13:08
hola Javixu (y Snakejic )

A parte de lo que ya te mencionó Snake,
Javixu escribió:
15 Abr 2019 12:48
en el ejemplo que adjunto, se ve cómo intento que me busque el valor 90.00 (valor exacto, la mayoría contienen decimales) y me devuelva 1.11, pero me da 1001.

He probado poniendo al final:

=BUSCARV(E1,A1:B117,2,VERDADERO)
=BUSCARV(E1,A1:B117,2, FALSO)
=BUSCARV(E1,A1:B117,2)

y siempre me da 1001 (el último número de la columa 2).
No te creo :shock: que en la segunda opción, en la que colocaste; Falso, te de 1001. :mrgreen:
a ver, vuelve a intentar :shock:

Otra cosa, 1 equivale a Verdadero, 0 Equivale a Falso, en la ayuda de Excel además te indica que Verdadero ú Omitido es lo mismo..

Cierto, con la segunda opción me encuentra 1.11 correctamente, no sé porqué pensaba que me estaba fallando,. supongo que después de probar tanto al final ya pensaba que me fallaba todo...

Entonces, parece que tengo el problema con la búsqueda aproximada!
Si busco 91.00 y pongo Verdadero (o 1), por qué me da 1001? en vez de 1.10 (1.11 también me valdría en caso de aproximar a la baja)??

En otras ocasiones sí me ha funcionado. No entiende por qué ahora no!



Avatar de Usuario
silvia quispe
Miembro Frecuente
Miembro Frecuente
Mensajes: 6753
Registrado: 13 Jul 2010 16:35
Ubicación: Lima-Perú

Re: Problemas con Vlookup (buscarv)

Mensaje por silvia quispe » 15 Abr 2019 16:12

Javixu escribió:
15 Abr 2019 13:49
Entonces, parece que tengo el problema con la búsqueda aproximada!
Si busco 91.00 y pongo Verdadero (o 1), por qué me da 1001? en vez de 1.10 (1.11 también me valdría en caso de aproximar a la baja)??

En otras ocasiones sí me ha funcionado. No entiende por qué ahora no!
porque parece que te faltó leer bien el comentario de Snake
Snakejic escribió:
15 Abr 2019 12:59
Para búsqueda aproximada tienes que ordenar tus datos por la columna A de menor a mayor.

....



Javixu
Miembro Frecuente
Miembro Frecuente
Mensajes: 73
Registrado: 19 Jun 2012 13:39

Re: Problemas con Vlookup (buscarv)

Mensaje por Javixu » 16 Abr 2019 09:07

silvia quispe escribió:
15 Abr 2019 16:12
Javixu escribió:
15 Abr 2019 13:49
Entonces, parece que tengo el problema con la búsqueda aproximada!
Si busco 91.00 y pongo Verdadero (o 1), por qué me da 1001? en vez de 1.10 (1.11 también me valdría en caso de aproximar a la baja)??

En otras ocasiones sí me ha funcionado. No entiende por qué ahora no!
porque parece que te faltó leer bien el comentario de Snake
Snakejic escribió:
15 Abr 2019 12:59
Para búsqueda aproximada tienes que ordenar tus datos por la columna A de menor a mayor.

....

Toda la razón. Perdonad que ayer ya tenía la cabeza hecha un bombo y mi sentido de deducción no estaba funcionando demasiado bien!



Avatar de Usuario
silvia quispe
Miembro Frecuente
Miembro Frecuente
Mensajes: 6753
Registrado: 13 Jul 2010 16:35
Ubicación: Lima-Perú

Re: Problemas con Vlookup (buscarv)

Mensaje por silvia quispe » 16 Abr 2019 11:09

:lol: :lol: :lol: :lol:



eduareliashm
Miembro Nuevo
Miembro Nuevo
Mensajes: 1
Registrado: 12 Jun 2019 23:52

Re: Problemas con Vlookup (buscarv)

Mensaje por eduareliashm » 13 Jun 2019 00:08

para aproximar a decimales tienes que tener en cuenta:
Número (obligatorio): El número que va a ser redondeado.
Número decimales (obligatorio): La cantidad de decimales a la que se desea redondear.
pero un truco:
Excel: Un truco para obtener decimales sin redondeos
Al calcular un precio promedio en Excel aparecen, en general, más de dos decimales. Conozcamos una forma de dejar todo con centavos (dos decimales) pero sin “redondear hacia arriba”.
Martes, 17 de Septiembre de 2013

Tweet

Efectivamente, cuando limitamos los decimales aplicando formatos, Excel hace lo que se llama redondeo simétrico.

Cuando el primer decimal que se descarta es cinco o más, suma una unidad al último decimal que se mantiene. Entonces al redondear 9,676 a dos decimales, obtenemos 9,68.El problema se puede resolver con la función TRUNCAR que elimina los decimales, sin redondear. Por ejemplo, si tenemos una serie de valores en [A2:A10] y calculamos su promedio con =PROMEDIO(A2:A10), dejamos sólo dos decimales con =TRUNCAR(PROMEDIO(A2:A10);2). Esta función tiene dos argumentos:
* El primero es el valor a redondear. En este caso, el obtenido con la función PROMEDIO.

* El segundo es la cantidad de decimales que queremos conservar. En este caso, dos.

El uso de esta función tiene una segunda ventaja. Cuando aplicamos un formato los decimales se ocultan, pero siguen ahí. Por ejemplo, si sumamos 1,503 más 1,503, el resultado es 3,006. Hasta ahí, todo en orden. Pero si luego aplicamos formato de dos decimales a todas las celdas, la cuenta se verá 1,50 más 1,50 igual a 3,01.

Las milésimas que se descartan en los sumandos se hacen significativas en el total y suman un centavo. Este problema no aparece cuando no redondeamos con el formato sino con funciones como TRUNCAR.



Responder