Como numerar según criterio

Solo consultas sobre Funciones y Fórmulas Excel.
Reglas del Foro
1. Antes de hacer tu pregunta intenta con el buscador de este foro (muchas preguntas ya fueron respondidas antes!)
2. Si haces una nueva pregunta, es muy recomendable que adjuntes el ejemplo Excel para poder comprenderla mejor!
3. Realiza tu pregunta de forma clara, explicando bien cada paso de lo que haces y tendrás más probabilidad de respuesta!
Responder
diementi
Miembro Nuevo
Miembro Nuevo
Mensajes: 3
Registrado: 15 Mar 2019 16:30

Como numerar según criterio

Mensaje por diementi » 21 Ene 2020 16:19

Buenas, tengo una consulta
Tengo una base de datos con diferentes artículos que se repiten tantas veces, yo los quiero enumerar de 0 hasta la vez q termine dicho artículo, pero cuando cambio de artículo, quiero hacer que arranque de 0 nuevamente.
Para no hacerlo manualmente ya q es una lista larga, hay alguna solución que me brinden?

Dejo ejemplo para ver si explica mejor

A 0
A 1
A 2
A 3
A 4
B 0
B 1
B 2
B 3
C 0
C 1
C 2
C 3
C 4
C 5



diementi
Miembro Nuevo
Miembro Nuevo
Mensajes: 3
Registrado: 15 Mar 2019 16:30

Re: Como numerar según criterio

Mensaje por diementi » 21 Ene 2020 16:21

Quiero aclarar porque no pude editar el mensaje, que la columna A sería el artículo y en la columna B donde quiero enumerar cada uno.

A 0
A 1
A 2
A 3
A 4
B 0
B 1
B 2
B 3
C 0
C 1
C 2
C 3
C 4
C 5



Avatar de Usuario
silvia quispe
Miembro Frecuente
Miembro Frecuente
Mensajes: 7059
Registrado: 13 Jul 2010 16:35
Ubicación: Lima-Perú

Re: Como numerar según criterio

Mensaje por silvia quispe » 21 Ene 2020 18:08

Hola diementi
puedes probar con contar.si

Código: Seleccionar todo

 =CONTAR.SI($A$2:A3,A3)-1 
**En este ejemplo, los datos comienzan en A3
*** mi separador de argumentos es la coma, si el tuyo es otro, corriges.

saludos,
Silvia



diementi
Miembro Nuevo
Miembro Nuevo
Mensajes: 3
Registrado: 15 Mar 2019 16:30

Re: Como numerar según criterio

Mensaje por diementi » 22 Ene 2020 09:27

Espectacular, muchas gracias!



Responder