Atascado en una formula

Solo consultas sobre Funciones y Fórmulas Excel.
Reglas del Foro
1. Antes de hacer tu pregunta intenta con el buscador de este foro (muchas preguntas ya fueron respondidas antes!)
2. Si haces una nueva pregunta, es muy recomendable que adjuntes el ejemplo Excel para poder comprenderla mejor!
3. Realiza tu pregunta de forma clara, explicando bien cada paso de lo que haces y tendrás más probabilidad de respuesta!
Responder
JASSORIANO
Miembro Frecuente
Miembro Frecuente
Mensajes: 5
Registrado: 11 Nov 2019 14:32

Atascado en una formula

Mensaje por JASSORIANO » 11 Nov 2019 14:39

Tengo un rango de celdas (E9 a E19) en las cuales puede haber una A, una B etc
Y quiero contar las A que hay en ese rango, pero solo en las filas que sean pares

puse esta, pero me tira error:
=CONTAR.SI.CONJUNTO(RESIDUO(FILA(E9:E19);2);0;E9:E19;CARACTER(65))


muchas gracias.
alguien puede ayudarme por favor?



Avatar de Usuario
silvia quispe
Miembro Frecuente
Miembro Frecuente
Mensajes: 6888
Registrado: 13 Jul 2010 16:35
Ubicación: Lima-Perú

Re: Atascado en una formula

Mensaje por silvia quispe » 11 Nov 2019 16:43

Hola JASSORIANO

JASSORIANO escribió:
11 Nov 2019 14:39
pero solo en las filas que sean pares
fila Par :

opción 1 (formula matricial, en lugar de enter Control+Sheeft+Enter)

Código: Seleccionar todo

=SUMA(--(SI(ES.PAR(FILA(E9:E19)),E9:E19)="A"))
opción 2

Código: Seleccionar todo

=SUMAPRODUCTO((E9:E19="A")*ES.PAR(FILA(E9:E19)))
** mi separador de argumentos es la coma, si el tuyo es otro, corriges.


Saludos,
Silvia



JASSORIANO
Miembro Frecuente
Miembro Frecuente
Mensajes: 5
Registrado: 11 Nov 2019 14:32

Re: Atascado en una formula

Mensaje por JASSORIANO » 11 Nov 2019 18:28

muchas gracias silvia.
con la opcion dos me va de maravilla!!!
muchas gracias por tu ayuda



Avatar de Usuario
silvia quispe
Miembro Frecuente
Miembro Frecuente
Mensajes: 6888
Registrado: 13 Jul 2010 16:35
Ubicación: Lima-Perú

Re: Atascado en una formula

Mensaje por silvia quispe » 11 Nov 2019 19:04

silvia quispe escribió:
11 Nov 2019 16:43
Sheeft
de donde salió eso :?: :!: :!: :!: :shock:
es shift. :|
:mrgreen:
JASSORIANO escribió:
11 Nov 2019 18:28
con la opcion dos me va de maravilla!!!
:wink:



JASSORIANO
Miembro Frecuente
Miembro Frecuente
Mensajes: 5
Registrado: 11 Nov 2019 14:32

Re: Atascado en una formula

Mensaje por JASSORIANO » 12 Nov 2019 10:41

Silvia y si fuera igual pero buscar las celdas que contuvieran una A o sea, A a solas o por ejemplo tambien AS o tambien AL etc.. o sea que que contuiviera una A



Avatar de Usuario
silvia quispe
Miembro Frecuente
Miembro Frecuente
Mensajes: 6888
Registrado: 13 Jul 2010 16:35
Ubicación: Lima-Perú

Re: Atascado en una formula

Mensaje por silvia quispe » 12 Nov 2019 11:15

hola
JASSORIANO escribió:
12 Nov 2019 10:41
o sea que que contuiviera una A
solo que empiecen con A

Código: Seleccionar todo

 =SUMAPRODUCTO((IZQUIERDA(E9:E19,1)="A")*ES.PAR(FILA(E9:E19))) 
:wink:



JASSORIANO
Miembro Frecuente
Miembro Frecuente
Mensajes: 5
Registrado: 11 Nov 2019 14:32

Re: Atascado en una formula

Mensaje por JASSORIANO » 12 Nov 2019 16:35

SIlvia, eres una crack!!
Pero necesito no que empieze por A sino que contenga la A o que pueda preguntar si contiene A+, o sea una letra o varias dentro de un texto, pueden ser A+L, LA, LA+L, LAL y muchos mas casos.

Muchas gracias de antemano.
y perdona mi ignorancia.



Avatar de Usuario
silvia quispe
Miembro Frecuente
Miembro Frecuente
Mensajes: 6888
Registrado: 13 Jul 2010 16:35
Ubicación: Lima-Perú

Re: Atascado en una formula

Mensaje por silvia quispe » 12 Nov 2019 17:42

entonces así:

Código: Seleccionar todo

=SUMAPRODUCTO(ESERR(HALLAR("A",E9:E19))*ES.PAR(FILA(E9:E19)))  



Avatar de Usuario
ServandoV
Miembro Frecuente
Miembro Frecuente
Mensajes: 4132
Registrado: 14 May 2012 20:02
Ubicación: México

Re: Atascado en una formula

Mensaje por ServandoV » 12 Nov 2019 18:05

Hola JASSORIANO (y SILVIA :wink: )

La sugerencia de Silvia es muy buena, pero por las prisas omitió negar el error.
Solo añádele la función NO() así

Código: Seleccionar todo

 =SUMAPRODUCTO(NO(ESERR(HALLAR("A",E9:E19)))*ES.PAR(FILA(E9:E19)))
Recuerda cambiar la coma , por punto y coma ; si ese es tu separador de argumentos

Saludos
Servando Villalón



Avatar de Usuario
silvia quispe
Miembro Frecuente
Miembro Frecuente
Mensajes: 6888
Registrado: 13 Jul 2010 16:35
Ubicación: Lima-Perú

Re: Atascado en una formula

Mensaje por silvia quispe » 12 Nov 2019 18:20

ServandoV escribió:
12 Nov 2019 18:05
La sugerencia de Silvia es muy buena, pero por las prisas omitió negar el error.
:mrgreen:



Avatar de Usuario
silvia quispe
Miembro Frecuente
Miembro Frecuente
Mensajes: 6888
Registrado: 13 Jul 2010 16:35
Ubicación: Lima-Perú

Re: Atascado en una formula

Mensaje por silvia quispe » 12 Nov 2019 18:20

Gracias Servando



JASSORIANO
Miembro Frecuente
Miembro Frecuente
Mensajes: 5
Registrado: 11 Nov 2019 14:32

Re: Atascado en una formula

Mensaje por JASSORIANO » 13 Nov 2019 12:40

muchas gracias silvaaa y servandoo, asi perfectooo!!!



Responder