Espacios en blanco funcion buscar v

Solo consultas sobre Funciones y Fórmulas Excel.
Reglas del Foro
1. Antes de hacer tu pregunta intenta con el buscador de este foro (muchas preguntas ya fueron respondidas antes!)
2. Si haces una nueva pregunta, es muy recomendable que adjuntes el ejemplo Excel para poder comprenderla mejor!
3. Realiza tu pregunta de forma clara, explicando bien cada paso de lo que haces y tendrás más probabilidad de respuesta!
Responder
Angel Torres
Miembro Nuevo
Miembro Nuevo
Mensajes: 4
Registrado: 15 Jul 2019 13:33

Espacios en blanco funcion buscar v

Mensaje por Angel Torres » 15 Jul 2019 14:02

Buen día
Quiero remplazar los valores $- por N/A de la ultima columna

SAI SKU DESCRIPCIÓN PMP
2047 7613326005012 BACTRIM 400/80 MG CON 30 TAB $285.00
18848 7640133685557  IMNOVID 4 MG CAPS C21 $-
18609 A18609 14905 BARRERA CONV PRECOR C/MIC 29MM C5 $-
19163 18133 NEW IMAGEN BOLSA COLOSTO ARO N/A
17608 (01)153901 BOLSA NEW IMAGE BEIGE C/F 44MM $-
18537 18537 BARRERA CONVEXA PRECORT 32MM C5 N/A
1533 7360854 OFT GTS 5ML $598.31
3849 7501043161602 3TC 150MG TAB CAJ C/60 $4,348.62

Estoy utolizando la funcion: =SI.ERROR(BUSCARV(B2,'[6 (version 1).xlsb]SAI Hoja1'!$A$2:$AB$19973,23,FALSO),"N/A")

Pero el si. error no me remplaza los valores $- ya que si existen pero por presentacion tengo que sustituirlos por N/A. ¿ Como puedo sustituir esos valores que no quiero?



Angel Torres
Miembro Nuevo
Miembro Nuevo
Mensajes: 4
Registrado: 15 Jul 2019 13:33

Re: Espacios en blanco funcion buscar v

Mensaje por Angel Torres » 15 Jul 2019 14:06

Así se ve la columna que quiero modificar

PMP
$285.00
$-
$-
N/A
$-
N/A
$598.31
$4,348.62



Avatar de Usuario
torquemada
Miembro Frecuente
Miembro Frecuente
Mensajes: 335
Registrado: 20 Nov 2012 22:13

Re: Espacios en blanco funcion buscar v

Mensaje por torquemada » 15 Jul 2019 14:36

Hola Angel.

Deberías de adjuntar un libro de excel con los datos.

Saludos.



Avatar de Usuario
ServandoV
Miembro Frecuente
Miembro Frecuente
Mensajes: 3980
Registrado: 14 May 2012 20:02
Ubicación: México

Re: Espacios en blanco funcion buscar v

Mensaje por ServandoV » 15 Jul 2019 14:44

Hola Angel (y Torquemada)

Si quieres que al realizar una búsqueda con BUSCARV y que cuando esta no se encuentre te marque N/A, lo que tienes que hacer es quitar el SI.ERROR y dejar la función BUSCARV sola:

=BUSCARV(B2,'[6 (version 1).xlsb]SAI Hoja1'!$A$2:$AB$19973,23,FALSO)

Saludos
Servando Villalón



Avatar de Usuario
hansabel
Miembro Frecuente
Miembro Frecuente
Mensajes: 353
Registrado: 01 Jul 2005 21:10
Ubicación: Santa Cruz-Bolivia

Re: Espacios en blanco funcion buscar v

Mensaje por hansabel » 15 Jul 2019 17:02

Si no quieres borrar el si.error en lugar de "#N/A" puedes poner nod()



Avatar de Usuario
Héctor Miguel
Miembro Frecuente
Miembro Frecuente
Mensajes: 5563
Registrado: 26 Mar 2005 18:31

Re: Espacios en blanco funcion buscar v

Mensaje por Héctor Miguel » 16 Jul 2019 00:47

Angel Torres escribió:
15 Jul 2019 14:02
Quiero remplazar los valores $- por N/A de la ultima columna ...

... la funcion: =SI.ERROR(BUSCARV(B2,'[6 (version 1).xlsb]SAI Hoja1'!$A$2:$AB$19973,23,FALSO),"N/A")

Pero el si. error no me remplaza los valores $- ...
prueba con:

Código: Seleccionar todo

=SI.ERROR(SUSTITUIR(BUSCARV(B2,'[6 (version 1).xlsb]SAI Hoja1'!$A$2:$AB$19973,23,FALSO),"$-","N/A"),"N/A")
es posible que no sea requerida la funcion SI.ERROR(... -?-



Responder