Contar Días de Semana en Fechas

Aporta funciones y cálculos Excel de interés para la comunidad.
Reglas del Foro
Este foro no es para hacer preguntas!
Este foro solo es para que aportes algo de interés para la comunidad.
(para preguntas vuelve al índice y busca los foros de "Tus Preguntas a la Comunidad")
Responder
Avatar de Usuario
Adrian
Moderator
Moderator
Mensajes: 6424
Registrado: 13 Jun 2004 17:24
Ubicación: Chamical La Rioja ARG

Contar Días de Semana en Fechas

Mensaje por Adrian » 10 Abr 2014 20:54

Hola, a veces tenemos una serie de fechas y deseamos contar las fechas de un mes en particular, y ponemos algo así: =SUMAPRODUCTO(--(MES(El Rango) = Nro del Mes)) y listo, pero si deseamos contar los días de una semana en particular lo lógico sería colocar:=SUMAPRODUCTO(--(NUM.DE.SEMANA(El Rango)=Nro de Semana))
Se lo soluciona con =SUMAPRODUCTO(--(NUM.DE.SEMANA(El Rango + 0) = Nro de Semana)) en definitiva le agregamos el 0 y Excel la torna una matriz, por que? eso no lo sé, pero es un recurso que me fue últil.
Pongo Archivo.
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.



rcortez
Miembro Frecuente
Miembro Frecuente
Mensajes: 41
Registrado: 22 Feb 2013 07:56

Re: Contar Días de Semana en Fechas

Mensaje por rcortez » 18 Abr 2014 01:49

esta fórmula también soluciona el problema:
=CONTAR.SI(C2:C55;F3)

Saludos desde Santa Cruz, Bolivia.



Avatar de Usuario
Adrian
Moderator
Moderator
Mensajes: 6424
Registrado: 13 Jun 2004 17:24
Ubicación: Chamical La Rioja ARG

Re: Contar Días de Semana en Fechas

Mensaje por Adrian » 21 Abr 2014 11:26

Hola rcortez, la "idea" es no usar columnas auxiliares, o sea no se debe tener en cuenta la columna C, por eso el uso de la función SUMAPRODUCTO, se entiende?



Responder